Telephone System Problems
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 27, 2019 - 16:52 GMT
Investigating
We are currently experiencing an intermittent fault with our telephone system which is leading to some incoming calls being randomly disconnected. We are investigating this in conjunction with our telephony supplier, and recommend that customers requiring technical assistance use the ticketing system in their Online Control Panel.
Posted 8 months ago. Feb 26, 2019 - 12:19 GMT
This incident affected: Phone System.