Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 20:00 BST
Scheduled
Work will be carried out on devices that sit in front of the our website, control panel and webmail services. the redundant path will be upgraded and rebooted. The active path will be failed over and then be upgraded and rebooted. During this period we will be running at risk due to reduced redundancy.
Posted Oct 22, 2025 - 09:10 BST
This scheduled maintenance affected: Control Panel, WebMail, and Website.