Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 20:49 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 20:00 GMT
Update
We are updating a platform that our forwarding and mxprotect services rely on. During the maintenance window of 20:00 to 23:00 there will be the potential for a very short disruption, which we hope few will notice. We apologise for any inconvenience this might cause.
Posted Feb 27, 2025 - 17:08 GMT
Scheduled
We are updating a platform that our forwarding and mxprotect services rely on. During the maintenance window of 20:00 to 23:00 there will be the potential for a very short disruption, which we hope few will notice. We apologise for any inconvenience this might cause.