Some customers may be unable to connect to their Office365 mailbox
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 23 days ago. Jan 28, 2019 - 17:09 GMT
Investigating
Some Office365 users may currently be experiencing problems connecting to their mailboxes. This is due to a known fault within the Microsoft network, that Microsoft are currently investigating. If you have access to your Office365 administrator account then you should see the latest update from Microsoft within the "Service Health" section of your Office365 portal.

We have also copied it below for your convenience.

User Impact: Users are unable to connect to the Exchange Online service via multiple protocols.

More info: As a result of this issue, users are receiving an error message indicating the number of concurrent connections has exceeded a limit when they attempt to send and receive email.

Current status: Our telemetry data is indicating connection time outs within the Exchange authentication infrastructure, resulting in impact to the service. We're looking into the Domain Controller logs to understand the cause and remediate impact.

Scope of impact: Impact is specific to users who are served through the affected infrastructure.

Start time: Thursday, January 24, 2019, at 9:00 AM UTC

Preliminary root cause: A subset of our managed Domain Controllers were in a degraded state, affecting Exchange Online functionality.
Posted 26 days ago. Jan 25, 2019 - 11:16 GMT
This incident affected: Office365 Services.