All fibres and links are now available as normal and full network resilience has been restored.
We will keep under monitoring overnight but are not anticipating any further unplanned works.
Posted Jun 19, 2025 - 11:11 BST
Monitoring
All fibres and links are now available as normal and full network resilience has been restored.
We will keep under monitoring overnight but are not anticipating any further unplanned works.
Posted Jun 17, 2025 - 19:52 BST
Investigating
Our network teams have identified multiple independent fibre cuts across multiple suppliers that are impacting usual resilience to our IP transit network that feeds our UK hosting services. The network is still available and at full capacity, however we consider this an at-risk situation until these links are recovered by the suppliers and are closely tracking their progress.