Names.co.uk Webmail & BT Broadband
Incident Report for Namesco Limited
Resolved
We have received confirmation from BT that this issue should now be resolved. It would have affected any BT Broadband customers using the optional "Web Protect" feature, and those customers should now be able to access the Webmail login page as they usually would.
Posted Dec 13, 2019 - 09:28 GMT
Investigating
We are aware that some customers using BT Broadband may be experiencing problems trying to load the Webmail login page at http://webmail.names.co.uk

We are looking into this at the moment, and will update this notification when we have further information.

In the meantime, affected customers should use the alternative login page at https://www.wmlogin.co.uk

If you have any further queries regarding this, please create a support ticket through the "Technical Support" section of your Control Panel and we will be happy to assist further.
Posted Dec 12, 2019 - 11:30 GMT