Issues with payments and adding cards
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 15:27 BST
Investigating
We're currently working with our payment gateway provider to identify the cause of issues some customers are experiencing with making payment and adding payment cards via the names.co.uk website.

As soon as further information becomes available, updates will be added to this page.

Please accept our sincere apologies for any inconvenience this may be causing.
Posted Oct 13, 2020 - 15:16 BST