Email issues with mail relay to Microsoft
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 4 months ago. May 15, 2019 - 17:01 BST
Update
Microsoft has now confirmed that the blocked IP has been re-instated and should be flowing as normal.

They have also provided the following explanation:

“Also we would like to inform you that, Microsoft operates numerous technologies and utilizes various sources of information to reduce the delivery of unwanted mail to customers' inboxes. Hence as a matter of policy, we do not discuss the details about our safety technologies, so we cannot discuss the reasons why a specific IP address is blocked.”
Posted 4 months ago. May 10, 2019 - 19:47 BST
Monitoring
Our own testing and customer feedback has confirmed that mail traffic that was previously blocked is beginning to pass to Microsoft services and so customers should see mail delivered as standard. Microsoft however has not yet confirmed that the block has been removed and we have a number of outstanding queries with them to seek confirmation. We are continuing to request information from Microsoft about why this issue has arisen but to date have received no feedback. We will keep pushing.

We will be monitoring the situation closely and should the position change we will post an update.

Once again, thank you for your continued patience whilst we have been battling with Microsoft. Please accept our apologies for the inconvenience caused by this very frustrating interruption.
Posted 4 months ago. May 10, 2019 - 16:54 BST
Update
We are still awaiting any sensible response from Microsoft and so for those customers that are still experiencing difficulties, could we please ask you to log into your names.co.uk WebMail where you should now be able to successfully send and receive emails to Microsoft. We will continue to push Microsoft to resolve the situation fully.
Posted 4 months ago. May 10, 2019 - 13:15 BST
Update
Microsoft has now de-listed most IP's that were being blocked and so most customers will no longer be experiencing issues delivering to Microsoft services. One IP remains an issues and we are continuing to lobby Microsoft to remove this final block. Microsoft unfortunately refuses to provide any information to us regarding the rationale behind this block on the basis that any information could impact the security of their systems. As you can appreciate we are finding it difficult to work with no information but we will continue to investigate. Thank you for bearing with us whilst we have been dealing with this very challenging situation and we will provide further information as it becomes available.
Posted 4 months ago. May 10, 2019 - 08:21 BST
Update
This evening we are continuing our dialogue with Microsoft engineers and pushing forward with our request for de-listing and further information about the current status. Some previously blocked email traffic is now passing although we also still observe failures due to blocks still in place and are aware that it is not yet universally resolved. We have been continuously raising this with the escalation channels at Microsoft at the highest priority. Thank you for your patience whilst we ask for this to be resolved.
Posted 4 months ago. May 09, 2019 - 22:10 BST
Update
Finally we are getting some traction with our complaint to Microsoft. We have engaged with Microsoft Critical Service Managers and Senior Support Escalation and are being suitably assertive in our interaction to get this resolved. Once again, thanks for bearing with us.
Posted 4 months ago. May 09, 2019 - 18:30 BST
Update
We are extremely sorry for the continued issues this afternoon. We have opened as many channels to Microsoft as possible and are continuing to push to get the issue resolved. We have received confirmation that Microsoft has logged the delisting request and that and that it is currently in progress, but unfortunately they are unable to provide a resolution time at present. We will continue to push Microsoft through all channels until the issue has been resolved. Thank you again for your continued patience and understanding.
Posted 4 months ago. May 09, 2019 - 16:31 BST
Update
We are continuing to work with Microsoft to resolve this incident as quickly as possible, and thank customers for their patience and understanding.
Posted 4 months ago. May 09, 2019 - 11:51 BST
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. May 09, 2019 - 09:40 BST
Identified
We have identified that Microsoft is currently blocking email relay for some of our IP ranges and this will result in customers experiencing problems when sending or receiving to Microsoft managed addresses. Our System Administrators are currently working with Microsoft to resolve the issue. We will provide an update at the earliest opportunity.
Posted 4 months ago. May 09, 2019 - 09:13 BST
This incident affected: Email - POP3/IMAP Access, WebMail, and Email - SMTP Authentication.