Hotmail / Outlook delivery problems
Incident Report for Namesco Limited
Resolved
Microsoft have resolved the issue. Thank you for your patience.
Posted 10 months ago. Mar 10, 2018 - 04:45 GMT
Identified
We are still waiting on Mircosoft to resolve the issue, we will updated you as soon as we get further updates. Thank you for your patience.
Posted 11 months ago. Mar 09, 2018 - 16:58 GMT
Update
Dialogue with Microsoft continues, as we work towards a resolution as rapidly as we can. Thank you for your patience.
Posted 11 months ago. Mar 09, 2018 - 11:46 GMT
Update
We are in communication with Microsoft regarding this and will provide further updates as soon as we have them. We thank customers for their patience and understanding.
Posted 11 months ago. Mar 09, 2018 - 09:59 GMT
Investigating
We are currently experiencing email delivery problems to Hotmail / Outlook email addresses. Customers using Webmail or Authenticated SMTP to email Hotmail recipients may receive a bounceback informing them that their email could not be delivered.

We are investigating this as a priority and will post further updates here as soon as we have them.
Posted 11 months ago. Mar 09, 2018 - 09:45 GMT