Problem with 0345 phone number
Incident Report for
Namesco Limited
Resolved
This incident has been resolved.
Posted
Aug
17
,
2026
-
16:47
BST
Investigating
We are currently investigating a problem receiving calls to our 0345 phone number. Whilst we work to resolve this, customers who need to speak to us should be able to get through on 01905 342342. The teams are standing by ready to take your calls.
Posted
Aug
17
,
2026
-
11:38
BST
This incident affected: Phone System.
×
Subscribe to Incident
Subscribe to updates for
Problem with 0345 phone number
via . You'll receive .