Telephone System - Intermittent Call Drops
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted Oct 25, 2019 - 14:29 BST
Investigating
We are currently experiencing intermittent call drops on our incoming lines. This has been raised as a fault with BT, who are investigating this as a priority. We apologise to any customers who may have been affected by this whilst talking to one of our advisors, and we will update this notification as soon as we have news from BT.
Posted Oct 24, 2019 - 16:44 BST
This incident affected: Phone System.