Names.co.uk Webmail
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 14:20 GMT
Update
This issue has now been resolved, and customers should now continue using https://webmail.names.co.uk as normal.

We apologise for any inconvenience this may have caused.
Posted Nov 25, 2019 - 14:20 GMT
Investigating
Customers may be experiencing problems loading the Webmail login page at https://webmail.names.co.uk

We are investigating this as a priority, and will update this notification as soon as we have an update.

Affected customers could try using https://wmlogin.co.uk as an alternative address, which should allow access as normal.
Posted Nov 25, 2019 - 14:18 GMT
This incident affected: WebMail.