Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2024 - 22:00 BST
Scheduled
During the scheduled window we will be carrying out work on infrastructure that supports the function of webmail, website and control panel services. During this period their maybe brief interruptions to those services.
Posted Sep 25, 2024 - 00:21 BST
This scheduled maintenance affected: Control Panel, WebMail, and Website.