Phone System Problems
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted Aug 09, 2019 - 13:16 BST
Investigating
We are currently experiencing a problem with our inbound telephone lines, which may lead to problems contacting us by phone. We are investigating this as a priority and hope to have it resolved shortly.

If your query is not urgent we recommend submitting an enquiry through your Control Panel.

We apologise for any inconvenience this may be causing.
Posted Aug 09, 2019 - 11:49 BST
This incident affected: Phone System.