Phone Line Issues
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted May 14, 2021 - 10:39 BST
Investigating
We are currently aware of an issue with the phone lines for our office, as a result the local 01905 numbers are not available. This is being investigated by our phone provider.
You can still reach our teams on the following numbers:
0345 363 363 2 – Sales
0345 363 363 3 – Customer Care
0345 363 363 4 – Technical Support
0345 363 363 5 – Dedicated Servers Support
0345 363 363 6 - Domain Administration
Posted Apr 09, 2021 - 12:37 BST
This incident affected: Phone System.