Phone System Problems
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 22 days ago. Jan 29, 2019 - 17:01 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 22 days ago. Jan 29, 2019 - 14:48 GMT
Investigating
We are currently experiencing a problem with our telephone system, affecting our ability to receive calls into our Contact Centre. We are investigating this with our telephony provider, and recommend that customers requiring assistance create a support enquiry through their Online Control Panel.
Posted 22 days ago. Jan 29, 2019 - 14:33 GMT
This incident affected: Phone System.