Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 23:00 GMT
Update
During this maintenance we will be upgrading external connectivity and one of our LINX connections will be out of service while it is upgraded. Customers' service is not expected to be impacted but customers may see traffic to/from external sites taking different paths across our network and to/from the Internet.
Posted Mar 20, 2025 - 10:49 GMT
Scheduled
During this maintenance we will be upgrading external connectivity and one of our LINX connections will be out of service while it is upgraded. Customers service is not expected to be impacted but customers may see traffic to/from external sites taking different paths across our network and to/from the Internet.