Intermittent problems with incoming lines
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 08, 2018 - 16:38 GMT
Investigating
We are currently experiencing intermittent problems with our incoming lines, meaning that some customers may have their call dropped or even be unable to call us at all. Telephone engineers are investigating this as a priority, and we hope to have it resolved as soon as possible.
Posted about 1 month ago. Nov 08, 2018 - 09:58 GMT
This incident affected: Phone System.