Email Platform Issues
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 11, 2017 - 15:39 BST
Monitoring
At 13:16 the incident was resolved and customer devices will now successfully connect to receive email.

There may be a short delay as emails sent are delivered to customer inboxes.

Our System Administrators are currently investigating the problem and we will update as soon as possible.

Once again please accept our apologies for this short interruption.
Posted 3 months ago. Sep 05, 2017 - 13:30 BST
Investigating
Currently some customers may be experiencing password errors as devices are connecting to our Servers when retrieving email. There are also some issues reported with receiving email from external addresses.

We are currently investigating and will update at the first opportunity. Please accept our sincerest apologies for this inconvenience.
Posted 3 months ago. Sep 05, 2017 - 12:49 BST