Telephone System
Incident Report for Namesco Limited
Resolved
The issues with our phone lines have now been resolved. We apologise for any inconvenience caused and thank you for your patience.
Posted Aug 01, 2022 - 11:21 BST
Identified
We are currently experiencing issues with our phone system. Unfortunately, this means we cannot handle any incoming or outgoing phone calls.

Our teams are standing by ready to provide support by ticket. You can create a ticket through your Online Control Panel, and we will be in touch as soon as possible.

We are working to get this resolved as soon as possible. We appreciate your patience and are sorry for any inconvenience this may cause.
Posted Aug 01, 2022 - 09:07 BST
This incident affected: Phone System.