Site visibility
Incident Report for Namesco Limited
Resolved
Issues surrounding SiteMaker websites earlier today have now been resolved.

We appreciate your patience on this matter.
Posted 6 months ago. Mar 28, 2018 - 13:15 BST
Monitoring
Sitemaker website visibility issues are now resolved.

We are aware of potential speed issues with these sites and our engineers are continuing to investigate this.
Posted 6 months ago. Mar 28, 2018 - 12:36 BST
Investigating
We are aware of an issue affecting some Sitemaker websites, our engineers are currently working on restoring visibility as soon as possible.

Please accept our apologies for any inconvenience this is causing.
Posted 6 months ago. Mar 28, 2018 - 11:32 BST