SiteMaker websites and editors
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 08, 2018 - 13:02 BST
Investigating
Websites and editors that use our SiteMaker packages may currently be displaying a Bad Gateway error or timeout. This is intermittent and subsequent refreshes of the page may cause it to display fine. We are investigating this, and apologise for any inconvenience.
Posted 4 months ago. Aug 08, 2018 - 10:24 BST