SiteMaker websites and editors
Incident Report for Namesco Limited
Resolved
Affected SiteMaker websites and editors are now back online and, after a period of intensive monitoring, we are happy to mark this incident as Resolved. We apologise to any customers who may have been affected by this, and if you have any further queries please raise a support ticket through your Online Control Panel.
Posted 7 months ago. May 03, 2018 - 16:04 BST
Investigating
SiteMaker websites and editors are unavailable at present. We are investigating as a priority, and will post a further update as soon as we have more news.
Posted 7 months ago. May 03, 2018 - 14:42 BST