Hotmail Delivery problems
Incident Report for Namesco Limited
Resolved
Microsoft have resolved the issue. Thank you for your patience.
Posted 10 months ago. Mar 17, 2018 - 07:05 GMT
Identified
We are waiting on Microsoft to resolve the issue, we will update you as soon as we hear from them. Thank you for your patience.
Posted 10 months ago. Mar 16, 2018 - 17:36 GMT
Investigating
We are currently experiencing email delivery problems to Hotmail / Outlook email addresses. Customers using Webmail or Authenticated SMTP to email Hotmail recipients may receive a bounceback informing them that their email could not be delivered.

We are investigating this as a priority and will post further updates here as soon as we have them.
Posted 10 months ago. Mar 16, 2018 - 09:03 GMT