SiteMaker websites and editors
Incident Report for Namesco Limited
Resolved
This problem has now been rectified and affected SiteMaker websites and editors are now back online and operational. We apologise for any inconvenience this may have caused.
Posted 10 months ago. Nov 01, 2017 - 10:53 GMT
Investigating
We are aware that websites using our SiteMaker web builder may currently be displaying an error message. This is being investigated as a priority and we will provide further updates as soon as possible
Posted 10 months ago. Nov 01, 2017 - 10:07 GMT