Office365 sign-in problems
Incident Report for Namesco Limited
Resolved
Microsoft have reported that they have now resolved this problem, so users should now be able to access their Office365 mailbox as normal. If you are continuing to experience problems please open a ticket as usual via your Online Control Panel.
Posted 8 months ago. Apr 06, 2018 - 13:10 BST
Investigating
Some Office365 users may currently be unable to sign-in and access their emails, either via the Outlook Web Interface or desktop / mobile clients.

Microsoft have confirmed this is a known problem that they are investigating, and they have an open incident alert on https://status.office365.com regarding this.

We will monitor the situation and update this page once Microsoft have provided further information.
Posted 8 months ago. Apr 06, 2018 - 11:09 BST