Hotmail / Outlook delivery problems
Incident Report for Namesco Limited
Resolved
We have been monitoring email delivery to Hotmail and are happy to confirm that everything is now operating normally.
Posted 8 months ago. Mar 21, 2018 - 13:01 GMT
Monitoring
We are seeing successful emails deliveries to Hotmail address and have had a confirmation that Microsoft have applied the removal, however they have stated it could take up to 24 hours to fully be removed from all the systems on their end.
Posted 8 months ago. Mar 20, 2018 - 21:06 GMT
Update
The case has been escalated within Microsoft, and we await the results of their investigation. This page will be updated as soon as we have further news, and we thank customers for their patience during this incident.
Posted 8 months ago. Mar 20, 2018 - 15:56 GMT
Update
We are still waiting for Microsoft to resolve the issue. We will let you know when we have any further updates. Thank you for your patience.
Posted 8 months ago. Mar 20, 2018 - 09:20 GMT
Update
We are still wiating on Microsoft to resolve the issue, as soon as we have further infomation, we will update you. Thank you for your patience
Posted 8 months ago. Mar 19, 2018 - 17:13 GMT
Update
We are waiting on Microsoft to resolve the issue, we will update you as soon as we hear from them. Thank you for your patience
Posted 8 months ago. Mar 19, 2018 - 11:54 GMT
Identified
We are currently experiencing email delivery problems to Hotmail / Outlook email addresses. Customers using Webmail or Authenticated SMTP to email Hotmail recipients may receive a bounceback informing them that their email could not be delivered.

We have investigated and identified the cause and are waiting on Microsoft to address the issue, will post further updates here as soon as we have them
Posted 8 months ago. Mar 19, 2018 - 08:38 GMT