Cpanel Hosting
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 08, 2018 - 13:03 GMT
Investigating
Some customer websites hosted on our Cpanel platform may currently be unavailable. We are actively investigating this with a high priority, and apologise for any inconvenience it may be causing.
Posted 4 months ago. Mar 08, 2018 - 11:16 GMT