Delivery of forwarded emails to BT & Yahoo addresses
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 28, 2017 - 14:39 GMT
Investigating
As with several other providers, we are currently seeing some delivery delays and failures when forwarding emails to BT & Yahoo email addresses. We are looking into these and will provide further updates here as we have them.

We apologise for any inconvenience this may be causing.
Posted 11 months ago. Jan 16, 2017 - 16:21 GMT