Spoofed Email Bouncebacks
Incident Report for Namesco Limited
Resolved
This incident has been resolved.
Posted Jun 12, 2018 - 12:31 BST
Investigating
Some customers have been reporting receiving bounceback messages relating to emails that they did not send. This is a result of an increasingly common-place tactic known as 'Email Spoofing' which is being used by spammers.

What is Email Spoofing?

When a spammer sends his emails he doesn't want the sender to know his real email address so he uses special software to forge the sender's email address, often picking the email address of a random individual or organisation. If an email that he sends gets rejected by the destination mail server, the bounceback message will often be sent back to the spoofed sender address.

What can be done about it?

If the bounceback messages are relating to spoofed emails sent from randomaliases@yourdomain then you could log into your names.co.uk Online Control Panel and remove the Catch-all alias if you liked, meaning that you will then only receive emails that are sent specifically to the email aliases you have defined.

If the email address that is being spoofed is your own then this is somewhat more problematic, as there is no simple way to stop receiving these. You could setup a rule in your email client to delete all emails with a subject of 'Mail Delivery Failure' but this will also delete genuine bounceback messages for your own non-delivered emails (if any).

Often, spammers work in cycles and it is likely that they will have moved on to a new spam campaign within 24 hours or so, meaning that the batches of bounceback messages should start to peter out.

We understand that being in this situation is frustrating and we are continuing to sift through the examples that customers have been providing us but, short of blocking delivery of all bounceback messages, there isn't really a quick fix for this sort of issue. If we identify a pattern in the behaviour or content of the bounceback messages that we can filter out then we will, but it is quite often the case that there is no pattern with them.
Posted Jun 11, 2018 - 13:05 BST