Webmail & Online Control Panel performance problems
Incident Report for Namesco Limited
Resolved
Normal service has now been restored for Webmail and Online Control Panel, and we thank customers for their patience whilst we worked to resolve this.
Posted 5 months ago. Mar 27, 2017 - 16:03 BST
Investigating
We are currently investigating the cause of degraded performance on both Webmail and the Online Control Panel. We will update this notification once we have identified and resolved the cause of the problem, and apologise for any inconvenience it may be causing,
Posted 5 months ago. Mar 27, 2017 - 14:50 BST