Webmail Login Problems
Incident Report for Namesco Limited
Resolved
This has now been resolved, and customers should now be able to log into Webmail either via the 1-Click login links or manually via the login page.
Posted 5 months ago. Dec 22, 2016 - 17:27 GMT
Investigating
Some customers may be encountering problems logging into their Webmail accounts, particularly if trying to use the 1-Click Login links in the Online Control Panel.

We are investigating this and hope to have an update shortly.For now, logging in manually with the username and password via the login page at https://webmail.names.co.uk may provide a better experience for any customers affected by this.

We apologise for any inconvenience this may be causing.
Posted 5 months ago. Dec 22, 2016 - 17:15 GMT